Problem with iPhone app

Posted by: kts79

Problem with iPhone app - 01/12/2010 11:56

Hi

I have the Weatherzone app on my iPhone 4 and whenever I run the app I get a message box that keeps popping up saying "Network Error. There was an error fetching data. Please try again in a few minutes."

This error just keeps popping up. It happens while I am out and while I am at home using our wifi network. Because the error keeps popping up I can't even get in to the setttings of the app. I am using the latest version of the app, I upgraded it last week when I was notified of the update.

All other apps work ok, and I had the same problem when I was running the old iOS version (I was on 4.1 and updated to 4.2 yesterday).

I love weatherzone, and it would be so much more convenient if I could get the app working, rather than using a browser to go to the webpage.

Does anyone have any suggestions?

Kate
Posted by: kymm

Re: Problem with iPhone app - 01/12/2010 16:46

Hi Kate, I use my WZ app on my iphone 4 all the time, without any troubles. I was having similar troubles with other apps tho (like facebook). To fix them, I had to delete the app and install them again. But I dont know how that works with the WZ one, because you have to pay for it. Would you have to pay to download it again?
Posted by: kts79

Re: Problem with iPhone app - 01/12/2010 17:31

Hi Kymm

The app store recognises that you have already purchased it and allows it to be redownloaded for free.

I just deleted the WZ app and redownloaded/installed, it has let me get a bit further, I have put in my postcode and it says Greenacre (Updating) at the top, but then the error starts appearing again and no data ends up being displayed.

:-(
Posted by: Teddy

Re: Problem with iPhone app - 01/12/2010 17:49

I am too getting this error it says "updating" and then network error, I then have to close the app. Very frustrating as I have the paid version too.

Oh and iOS4.2.1 here as well.
Oh also happens on wifi (Internode ADSL2+) & 3g (vodafone)

Teddy
Posted by: kts79

Re: Problem with iPhone app - 01/12/2010 17:58

Hi Teddy

Yep, mine is the paid version too. Glad to know it is not just me! My internet is iinet ADSL 2+, so doesn't seem like it is isp related.

I have also tried with 3G turned on & off, but same problem.

Kate
Posted by: kymm

Re: Problem with iPhone app - 02/12/2010 22:46

Gosh, I hope it doesn't happen on mine. So far so good, Sorry to hear you guys are having so much trouble frown
Posted by: andy1

Re: Problem with iPhone app - 05/12/2010 16:56

The weatherzone app version 2.5 is working fine on my iphone 4 (Vodafone).